MMOGspot - Massively Multiplayer Community
Skip

New version of the game client

We kindly inform you that today the latest version of the game Legends of Aria, marked with the symbol 0.7.1b, is required to connect to the Aria MoonGate server. It introduces numerous adjustments optimizing the use of resources on the server and game client side. Link to the new client below:

http://cdn2.legendsofaria.com/LegendsOfAria-0.7.1b.exe

Post your comment