MMOGspot - Massively Multiplayer Community
Skip

New UO game client requred from tomorrow

Please be advised that from tomorrow, 01.07.2019, required for correct game on MoonGate version of the UO, there will be a version not lower than indicated by number:

UO Enhanced 3D – 4.0.76.4 (or higher)

UO Classic 2D – 7.0.76.4 (or higher)

The number of the currently installed version of the game is displayed on the login panel. Using the older version of the game will prevent connection to the server (kick game client).

Therefore, if you have an older version – please immediately update the Ultima installed on your computers by using the uopatch.exe file in the game folder.

Post your comment